DEMO İNCELE
ÜCRETSİZ İNDİR

Prestashop 1.5.0.17 den 1.5.1 stable sürüme geçiş

arkadaşlar merhaba,

manuel update denemesşi yapayim dedim önce; install sayfasına girince upgrade seçeneği çıkmadı direk sıfırdan kurulum yapmaya çalıştı.

bende 1-click upgrade modulünü kurdum siteye onunlada yükleme yaparken

Error detected during [restoreFiles]. şeklinde bir hata penceresi çıkıyor. tamam butonuna basıp kapatıyorum ve ekteki resimde de görüldüğü gibi bir ekran geliyor.

girdiğimiz ürünleri kaybetmeden başka nasıl son sürümü geçiş yapabilirim? bu kullandığım sürümde baya bi problem war sanırım. sepete ürün ekliyoruz başka sayfaya gidince sepettekiler boşalıyor falan. garip garip şeyler var. steble versyonunda düzelmiştir diyerekten güncelleme yapmak istiyorum.

16 thoughts on “Prestashop 1.5.0.17 den 1.5.1 stable sürüme geçiş

  1. MEG Venture - 29 Mart 2017 at 23:46

    Yardımı olur mu bilmiyorum ama ben de 1.5.0.17'den 1-click upgrade denedim, benzer hatalar aldım, manuel update denedim, cms dahil herşey daha da berbat oldu, sonra mecburen sıfırdan 1.5.1 kurup gerekil veritabanlarını manuel import ettim.

    İnşallah sen de bu yollardan geçmezsin. İmkanın varsa sıfırdan kurulum tavsiye ederim.

    Cevap
  2. SedatKar - 29 Mart 2017 at 23:46

    1.5.1 'in tema ve modul altyapısı komple değişmiş. nasıl olmuş derseniz , devamlı tema geiştiren biri olarak en berbat tema altyapısı olmuş.
    ben güncellemeyi denemedim ama büyük bir ihimalle tema altyapısından kaynaklanıyor bu.
    çağlar beyin söylediği yöntem en güzel yöntem bence güncelleme için.

    Cevap
  3. MEG Venture - 29 Mart 2017 at 23:46

    Safacım, yeri gelmişken bir ekleme de ben yapayım.

    Modül yapısı da artık multistore desteğini zorunlu kılıyor. Form yapısı için array tanımlamak gerekiyor.

    1.5 için tüm modüllerimi neredeyse sıfırdan tasarlamam gerekti diyebilirim.

    İşin ilginci, 1.5 için tasarlanan modüllerin artık 1.4.9 ve altı için çalışma şansı yok. Varsa da, bir o kadar uğraşmak gerekiyor.

    Bakalım sonu ne olacak?

    Cevap
  4. SedatKar - 29 Mart 2017 at 23:46

    aynı durum benim içinde geçerli. addons'tada sıkıntı çıkacak güncelleme yaparken adım gibi eminim.
    offf offff.

    Cevap
  5. burakco - 29 Mart 2017 at 23:46

    sıfırdan kurulum yaparsam eski sürümde girilen ürünleri nasıl son sürüme kopyalayabilirim?

    Cevap
  6. behcet - 29 Mart 2017 at 23:46

    hala 1.2.5 kullanıyorum ve kurcalamadık yerini bırakmadım.
    Açıkcası yeni sürümlere geçmek istiyorum ancak korkuyorum.

    Cevap
  7. MehmetGuler - 29 Mart 2017 at 23:46

    Adminx klasörü (sizdeki admin klasörü) içindeki tüm dosyaların (Unix) 666 permission olması gerekiyor. Bu şekilde denerseniz sorun çıkmayacaktır. Ama bu genel anlamda bir çözüm yolu. Bu sorun için sunucuya göre değişir diyebiliriz.

    Apache kullanıyorsanız ve destekliyorsa run as cgi modunda çalışırsanız dosya düzenlemesine bile gerek yok.
    Litespeed kullanıyorsanız klasörleri 777 dosyaları 666 yapmanız gerekiyor.
    Windows sunucu kullanıyorsanız bu sorunun olmaması muhtemeldir. (IIS için) Ama windows ile Prestashop ayrı dünyaların insanları.

    Siz dosya haklarını düzenleyip yeniden deneyin.

    İyi şanslar

    Cevap
  8. MehmetGuler - 29 Mart 2017 at 23:46

    Bu güncelleme konusu açılmışken:
    Prestashop ailesi olarak halen düzgün bir FTP katmanı geliştiremediğimiz için güncelleme kısa bir süre daha kabus olacak. Bu dosya güncelleme işleri PHP dili ile yapılacak işler değil. Ama gel anlat bunu. İngilizce forumda iki sene önce yazmışım. SVN'de 1 yıl önce patlak olan fonksiyonlar final sürümünde yine karşımıza çıkıyor. Zor birşey değil adamlar yapmış WordPress tek tıklama ile FTP ye bağlanıp 2 dakikada güncelliyor kendini.

    FTP iyi de güvenli mi peki ? diye soran olursa
    Cevap: php file komutlarından daha güvenli

    Arasıra güncelleme için bir modül yapmayı düşünüyorum ama çok uzun süreceği için vazgeçiyorum.

    Cevap
  9. burakco - 29 Mart 2017 at 23:46

    mahmut abi bu dediğini denicem bugün, umarım çözüm olur teşekkürler. modül konusunda da hayırlı haberlerini bekliyoruz. uğraştırma bizi böyle

    Cevap
  10. MEG Venture - 29 Mart 2017 at 23:46

    Yardımlar için teşekkürler.

    Madem her sunucu ayarı için dosya izin konfigürasyonu farklı oluyor, kurulumda bunun otomatik tespit edilip ikaz verilmesi uygun olmaz mı? Prestashop bu konuyu gündeme getirmenize rağmen duzeltmemekte neden ısrar ediyor acaba? İsterseniz İngilizce forumda bir konu açıp hep beraber yüklenelim.

    Bu arada upgrade modülü için harika olurdu desem de, sizi sevdiğimden uzak durun derdim. Merhametin dahi bir sınırı var.

    Selamlar.

    Cevap
  11. MehmetGuler - 29 Mart 2017 at 23:46

    mahmut abi bu dediğini denicem bugün, umarım çözüm olur teşekkürler. modül konusunda da hayırlı haberlerini bekliyoruz. uğraştırma bizi böyle

    Umarım bahsettiğim şekilde çözülür.

    Bu gün bir arkadaşımla görüştüm. Modül konusunda en çok tanınan ve en başarılı kişi diyebilirim. Aynı fikre sahipmiş. Fakat çok uzun sürer diyor. Birlikte yapalım dedim kabul ederse başlıyoruz. Fakat en az 15 gün sürer. Çünkü her farklı sunucu, sürüm için denemek lazım.

    Cevap
  12. MehmetGuler - 29 Mart 2017 at 23:46

    Yardımlar için teşekkürler.

    Madem her sunucu ayarı için dosya izin konfigürasyonu farklı oluyor, kurulumda bunun otomatik tespit edilip ikaz verilmesi uygun olmaz mı? Prestashop bu konuyu gündeme getirmenize rağmen duzeltmemekte neden ısrar ediyor acaba? İsterseniz İngilizce forumda bir konu açıp hep beraber yüklenelim.

    Bu arada upgrade modülü için harika olurdu desem de, sizi sevdiğimden uzak durun derdim. Merhametin dahi bir sınırı var.

    Selamlar.

    Bununla ilgili konu açmıştım daha önce ama SVN üzerinden ve e-postayla daha çok bildirdim.
    Şu an Prestashop ekibi aşırı büyük ve dışa kapalı çalışıyor. Topluluk olarak bir sürü deneyim biriktiriyoruz ama bakıyoruz ki kullanılmamış. Ayrıca sürekli kaptan değiştiren bir gemiye benziyor. Bu yüzden topluluk deneyimlerini yeterince kullanamıyorlar.

    Cevap
  13. burakco - 29 Mart 2017 at 23:46

    mahmut abi dediğin gibi admin klasöründe izinleri ayarladım fakat hala sıfırdan kurulum yapmaya çalışıyor, upgrade seçeneği çıkmıyor?

    Cevap
  14. MehmetGuler - 29 Mart 2017 at 23:46

    mahmut abi dediğin gibi admin klasöründe izinleri ayarladım fakat hala sıfırdan kurulum yapmaya çalışıyor, upgrade seçeneği çıkmıyor?

    config klasöründe settings.inc.php dosyasının olması gerekiyor. Bu dosya yok veya okunamıyor olabilir.
    Aslında isterseniz yarın mesai saatlerinde bana ulaşın direk kendim deneyeyim. Çünkü her sunucu ve sürümde farklı sorunlar çıkıyor. Şimdi burada görmediğimiz bir şey hakkında fikir yürütüyoruz ama çözülemiyor.

    Cevap
  15. burakco - 29 Mart 2017 at 23:46

    abi site için gerekli bilgileri mesaj olarak attım sana, bakabilirsen çok sewinirim

    Cevap

Cevap bırakın