DEMO İNCELE
ÜCRETSİZ İNDİR

Prestashop Linux VPS Serverda Kurulum Gerçekleşmeme Sorunu

Arkadaşlar merhabalar;

adresteki yardım talebimde sağ olsun Şahin YILDIZ hocam hosting firmasıyla görüşmemi önermişti. Bugün görüştüm. Ama sabahtan beri bir türlü sorunu çözemedik. Benim önceki mesajımdan farklı olarak soracağım bir soru daha var. O yüzden yeni bir başlık açmak istedim. Umarım hata yapmamışımdır.  Siz değerli arkadaşlarıma iki sorum olacak. Birincisi.
Dün ki hata verdiğinde Serverda PHP ayarları kısmında PHP support bölümünü Apache Module olarak seçmiştim. Bugün hosting firmasındaki arkadaş “FastGCI Applications” olarak seçmen gerek dedi. Windows Server 2003 sunucuda ben PHP Sürümü olarak 5.2.17 Çalıştırma modu olarakta ISAPI Extension seçiyordum. Sorun olmaksızın kurulum tamamlanıyordu. Ama Linux konusunda çok acemiyim. Yani Web Hosting ayarlarında ISAPI zaten yok. PHP versiyonunu seçebileceğim bir bölüm de yok.  PHP Support bölümünü Apache Module olarak mı; FastCGI Applications olarak mı yoksa CGI Applications olarak mı seçmeliyim? Birinci sorum bu. 
İkinci olarak ise hosting firmasındaki arkadaşın söylediği şekilde FastGCI Applications seçtiğimde de kurulum yapmaya çalıştığımda Sistem Gereklilikleri bölümünü yani System Compatibility bölümünü doğrudan geçiyor. Veritabanı ayarlarının yapıldığı adıma atlıyor ikinci adımdan dördüncü adıma atlıyor yani. Ama orada veritabanı bağlantısını test et dediğim de bir iç frame açarak birinci adıma dönmeye çalışıyor. Hata ayıklama modunu açarak hatayı bulmaya çalıştığımda ise aşağıdaki hata mesajıyla karşılaşıyorum. Bu hata prestadan mı kaynaklanıyor yoksa Serverdan mı onu anlayamadım. Bu iki sorum hakkında yardımcı olabilecek arkadaşlardan yardım rica ediyorum. Şimdiden teşekkür ederim. İkinci sorumdaki hata mesajı aşağıdaki gibidir.
 
Warning: session_start(): open(/var/lib/php/session/sess_m83le0p65lj93hg13egetou5l2, O_RDWR) failed: Permission denied (13) in /var/www/vhosts/siteadresim.com/httpdocs/install/classes/session.php on line 46 Warning: session_write_close(): open(/var/lib/php/session/sess_m83le0p65lj93hg13egetou5l2, O_RDWR) failed: Permission denied (13) in /var/www/vhosts/siteadresim.com/httpdocs/install/classes/session.php on line 56 Warning: session_write_close(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in /var/www/vhosts/siteadresim.com/httpdocs/install/classes/session.php on line 56

3 thoughts on “Prestashop Linux VPS Serverda Kurulum Gerçekleşmeme Sorunu

  1. SedatKar - 29 Mart 2017 at 23:52

    selamlar;

    whm üzerinden easyapache den .

    php sürümünü 5.5 veya üzeri. PDO_MySQL, mcrypt, GD gibi eklentileri kurarmısın

    videoda arkadaş meganto için ayarları yapıyor ama aynı şeyler prestashop içinde geçerli.

    hatların hepsi sunucu eklenti kaynaklı .

    Cevap
  2. siteuye - 29 Mart 2017 at 23:52

    Teşekkür ederim Safa;
    Hostingteki arkadaş ne yaptı anlamadım bana bilgi vermedi ama sorun çözüldü görünüyor. Ama acizane tecrübeli arkadaşlara bu konuyla alakalı başka bir soru sormak istiyorum. Yeni kiraladığım Linux VPS serverda Prestashop kurulumu yaparken Sistem Gereklilikleri bölümü yani dosya ve klasörlerin okuma yazma izinlerinin kontrol edildiği bölüm otomatik olarak geçiyor. Daha önce kullandığım Windows 2003 Server’da kurulum yaparken böyle olmuyordu. Linux olduğu için mi otomatik olarak geçiyor yani sizlerde de öyle mi oluyor yoksa hosting firmasından güvenlik ayarlarını en alt seviyeye aldılar da okuma-yazma izinlerine tümden erişim olduğu için mi böyle bir durum var? Bu konuda fikir verebilecek arkadaşlardan değerlendirme rica ediyorum. Şimdiden teşekkür ederim.

    Cevap
  3. SedatKar - 29 Mart 2017 at 23:52

    linux cpanel sunucularda yazma izinlerini otomatik verilebiliyor php özelliklerinden.

    dert edecek yada sıkıntı yaratacak bir durum yok endişe etmene lüzüm yok.

    plesk panelde verilemiyor.

    php yada prestashop için şuan en işleyişli sistem linux cpanel sunucudur.

    kolay gelsin

    Cevap

Cevap bırakın